Wednesday, January 24th 2018, 4:47am UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 76.

Wednesday, December 20th 2017, 4:08am

Author: v01d

uploading & debugging Externally Built Executable project

Quoted Where did you specify the bin file? Project Options -> Debug -> Loader -> Load file I spec'ed complete path to the externally built *bin file Quoted Where did you specify the bin file? Project Options -> Debug -> Loader -> Load File Address I put the address I want to load this to (as posted originally, in DDR , tested 0x80000000 or 0x87800000, depending on build) Quoted When did it ask you for an address? It only asked if I left "Load File address" field (see above) empty. This was firs...

Wednesday, December 20th 2017, 3:02am

Author: v01d

How to read iMX7's MDM-DAP registers with JLink

Thanks Nino for the information. I will need to spend some time checking this, if I find something that will fix it for me I will report here.

Wednesday, December 20th 2017, 2:52am

Author: v01d

JLinkExe's RSetType stopped working

Quoted from "SEGGER - Nino" Hi, The issue was reproducible with your sample. The statement: if (0 == MAIN_ResetType) can't be parsed correctly. Instead use MAIN_ResetType == 0. Then everything should be working as expected. We discuss internally if the parser will be expanded to support that order as well. Quoted The RSetType and my script used to work in version(s) before 6.20i Could you specify with what version it worked how you posted it? Because the script file parser has not been changed ...

Wednesday, December 20th 2017, 2:37am

Author: v01d

uploading & debugging Externally Built Executable project

Hi, Quoted Keep in mind that this is *not* a support forum. Yes, I was told multiple times, so I acknowledge I was informed about it. I didn't find I'm overusing or abusing the forum. However, I''ll note that me/we in process of deciding if we will pay for ES license(s), so trying to save time getting all setup with ES to see it does all needed. I'll get back to your questions on my actual question in a flash after I checked it.

Wednesday, December 20th 2017, 2:28am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

Hi, Thanks for replying Quoted Please familiarize yourself with the documentation of our products before opening numerous threads. This is my first Ozone related thread. Which other "numerous" ozone related thread you refer to? Quoted Now back to topic. Yes please stick to the topic rather, than complaining about me asking questions? Thank you for the useful part of that reply which I will try asap, no information passed will be wasted.

Tuesday, December 19th 2017, 1:42am

Author: v01d

uploading & debugging Externally Built Executable project

Any update, Nino? With Eclipse, I was able to do this within 5 minutes. Please provide some steps to do this with ES.

Tuesday, December 19th 2017, 1:41am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

Quoted from "SEGGER - Nino" Hello, This is also possible in Ozone. It is described in detail in the Ozone user manual in chapters 6 and 7.7/7.8. There you will find all options and combinations of downloading files and loading the according elf files and other options as well. Best regards, Nino Chapter 6 is Scripting interface, and 7 is Appendix , 7.7 Action Tables, 7.8 User Actions. Which one deals specifically with loading first a bin image followed by symbols? Do you have example? Chapter 5...

Sunday, December 17th 2017, 1:16am

Author: v01d

How to read iMX7's MDM-DAP registers with JLink

Hi, The silent fail behavior also repeats for a bunch of other (because I only tried few, possibly many more) registers when system runs. For the target in question, connected to A7_0 core, but before Linux has booted, you can access with JLink registers or SRC_A7RCR0 and SRS_M4RCR, for example. JLinkExe works and reads and writes. If you try access same registers after Linux has booted, (even after re-connect with JLinkExe), reading those registers silently fails.. (again no message of an sort)...

Sunday, December 17th 2017, 12:46am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

I'm trying to load a *.bin file built with external system, it is the one to be debugged, to be loaded at address specified by me. I want to use symbols file to be loaded separately. (this is to do with how it was built). For example, this setup is possible with DS-5 studio: you can load bin, specify symbols file from an elf later, and then also trigger re-load symbols at offset, they have console for this Which is all handy for a self-relocating code

Friday, December 15th 2017, 9:21am

Author: v01d

uploading & debugging Externally Built Executable project

So I tried this, for specified target iMX7D, A7_0 I selected. I specified a bin file, tried debug loading it, it asked me for load address , I spec'ed 0x80000000 (DDR) , and then I get error "0x80000000 - 0x800E5E93 load section does not fit the target description" The section it's showing is just matching the size of the bin file. The DDR is well much larger than that. Why is it complaining?

Friday, December 15th 2017, 8:04am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

How do I specify file with symbols for debugging when I've uploaded a *.bin file to target?

Thursday, December 14th 2017, 5:29pm

Author: v01d

JLinkExe's RSetType stopped working

I just tried latest version, and no the issue is there. (JLink_V622c) JLinkExe -device Cortex-M4 -autoconnect 1 -if JTAG -speed 4000 -JTAGConf -1,-1 -JLinkScriptFile my_NXP_iMX7D_Connect_CortexM4.JLinkScript the my_xx script is Segger's script with this addition: Source code 1 void ResetTarget(void) { // In case cores 1-3 are reset, we do nothing, // as we would lose connection to these cores, when resetting the device // as a reset disables the clock to them. Report(" ***** Custom ResetTarget c...

Wednesday, December 13th 2017, 3:15pm

Author: v01d

How to read iMX7's MDM-DAP registers with JLink

I tried reading DAP' status, control and ID registers on iMX7D module. The info and addresses are on p 258 of IMX7DRM manual. E.g. : IDR addr 0x010000FC, suppose to have fixed value of 0x0001c0000 Trying by connecting to A7_0: JLinkExe -device MCIMX7D7_A7_0 -autoconnect 1 -if JTAG -speed 4000 -JTAGConf -1,-1 mem32 0x010000FC, 1 This silently fails, with nothing printed, and no error or any trace returned. Tried through M4: JLinkExe -device Cortex-M4 -autoconnect 1 -if JTAG -speed 4000 -JTAGConf ...

Wednesday, December 13th 2017, 7:27am

Author: v01d

JLinkExe's RSetType stopped working

It seems after I installed v 6.20i, the JLinkExe's internal command RSetType stopped working. E.g. RSetType 1 (or 2, 3, 4 ... ) will print that the reset type was changed, however , in my script if (0 == MAIN_ResetType){ always evaluates to true. The RSetType and my script used to work in version(s) before 6.20i

Wednesday, December 13th 2017, 4:30am

Author: v01d

FreeRTOS plugin under Eclipse crash

Ah thanks, found the library. Will give it a go

Wednesday, December 13th 2017, 4:24am

Author: v01d

[SOLVED] any difference to "free" vs licensed SES?

Hi Johannes, Thank you for the info Could you clarify a few more things. Quoted currently based on STLPort. Does 'based' mean you have adopted/modified/improved that library? Just to understand, as their website says its free product, and you can download the sources, thus what did Segger add to make it non-free. From STLPort website it seems the supported compilers version are ancient a bit .. I didn't see which standard year it supports/complies with, does Segger's version support C++11 or lat...

Tuesday, December 12th 2017, 7:43am

Author: v01d

[SOLVED] show print margin in code editor

Does SES code editor support showing Print Margin? (ref. Eclipse C/C++ editor & others. (e.g. default 80chars width ))