Tuesday, February 20th 2018, 4:41pm UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 707.

Today, 2:20pm

Author: SEGGER - Nino

Compile C without assembler conversion

Hello Ilkay, You can import MBED projects already. This needs to be done manually though. For an export function in MBED please contact ARM as this is not our decision to make. From our side this would of course be appreciated. Best regards, Nino

Today, 1:55pm

Author: SEGGER - Nino

[Ozone]SWO issue

Hi Paco, Quoted Could you verify that this file is included in the "J-Link Software and Documentation pack for Linux"? Ok didn't have the information before that you are using Linux. In that case you need to do the "update" manually by moving the JLinkDevices.xml and Devices/ folder from the J-Link install folder to the Ozone install folder. Then the correct SWO sequence should be called when selecting a nRF52 device with Ozone. Best regards, Nino

Today, 1:32pm

Author: SEGGER - Nino

J-Link cannot connect to i.MX6ULL target

Hello Keishi, Thank you for your inquiry. You need to specify the exact device name. Currently you are trying to connect to a generic Cortex-A7 device which will not work. When Commander asks you for the device name you can either type "?" to get a list of supported devices or write it directly. The correct device names for imx devices can be found here: https://wiki.segger.com/IMX_Series_Devices Best regards, Nino

Today, 10:58am

Author: SEGGER - Nino

Cannot use JLinkRemoteServer on linux from windows' Keil: Max. number of connections exceeded.

Hello Marc, You write that you use a JlinkRTTServer. Can you elaborate what exactly do you mean by this? I could not find any software called like this. Did you mean JLinkRemoteServer instead? Multiple connections to J-Link over RemoteServer or IP are currently not supported. This might be implemented in future if the commands come from the same client PC. What is triggering the second connection? You write that Keil is doing it but we are not aware of such behaviour. Could you post a J-Link log...

Today, 10:36am

Author: SEGGER - Nino

[SOLVED] Can not find ICE-Pick (IDCODE mismatch)

Hello, Great to hear that you are up and running again. We will consider this case as closed now. Best regards, Nino

Today, 10:35am

Author: SEGGER - Nino

Segger Flasher ARM can't connect to Cypress' PRoC CYBLE-022001-00

Hello Fred, Thank you for your inquiry. Such an issue is not known to us. Are you trying to program custom hardware or an eval board? What target device are you selecting for connection? Could you try to connect to the target device using the J-Link commander and post a screenshot of the connection? https://wiki.segger.com/J-Link_cannot_co…-Link_Commander Does that generally work? Could you attach the config file you are using for programming? Could you also attach a J-Link log file of the faili...

Today, 9:49am

Author: SEGGER - Nino

[Ozone]SWO issue

Hi Paco, when using our software there is no ITM setting required from your application. It even will disable SWO connection in some cases. So remove any ITM settings from your code. To use SWO in Ozone make sure that you have run the JLinkDLLUpdater once from the J-Link software install folder. For this close any open Ozone window and apply the DLL update. Now you should see SWO automatically in Ozone when starting the debug session without needing to launch the Commander. Best regards, Nino

Today, 8:28am

Author: SEGGER - Nino

Compile C without assembler conversion

Hi Ilkay, Quoted I wonder if it uses the same principle quietly? Correct, they use the same princible C->Assembler->Obj, but delete Assemlber files afterwards. So it only looks like the conversion is direct. Best regards, Nino

Yesterday, 11:48am

Author: SEGGER - Nino

Break on ARM hard fault?

Hello Mike, Thank you for your inquiry. To set breakpoints you can either use monitor commands or a JLinkScript which then gets passed to VisualGDB. The monitor command you could use here is "setbp". More information can be found in the J-Link user manual. Best regards, Nino

Yesterday, 11:41am

Author: SEGGER - Nino

[Ozone]SWO issue

Hello, Thank you for providing additional information. Now it makes more sense, I thought you were using the JLinkSWOViewer. Are you using the PCA10040 eval board or some other? Could you provide a example project where the issue is reproducible? Could you try the latest Ozone and J-Link software release version to make sure we are not hunting any bugs that have already been solved? https://www.segger.com/downloads/jlink/ Best regards, Nino

Yesterday, 10:49am

Author: SEGGER - Nino

JLinkExe fails to connect to CC3220SF

Hello, Thank you for your inquiry. The CC3220 device family is currently not supported by J-Link. Listings on our webpage are incorrect and will be removed. According to TI they were able to establish connection to the CC3220 device with the CC3200 JLinkScript. But this could not be reproduced on our side yet with the CC3220 Launchpad. For more information please get into contact with TI. Best regards, Nino

Yesterday, 9:21am

Author: SEGGER - Nino

Compile C without assembler conversion

Hello Ilkay, Thank you for your inquiry. A direct conversion is generally not possible as the assembler file needs to be created as an intermediate step before getting object files. All other toolchains do it this way as well. Some "optimize" by deleting the assembler files after build. Best regards, Nino

Yesterday, 9:14am

Author: SEGGER - Nino

[Ozone]SWO issue

Hello Paco, Thank you for your inquiry. To use SWO in Ozone you need to configure it in Ozone. For this open your Ozone project and go to Edit->Trace Settings... -> trace source SWO. Does that solve the described behaviour? Best regards, Nino

Yesterday, 8:44am

Author: SEGGER - Nino

Ozone: v2.56b on Lubuntu: Missing root forward-slash in file paths

Hi, It seems that under certain circumstances the leading slash would disappear in the Linux version. This should be fixed now with the latest Ozone release: https://www.segger.com/downloads/jlink/#Ozone Could you try it out and give feedback if the issue is resolved for you as well? Best regards, Nino

Friday, February 16th 2018, 4:47pm

Author: SEGGER - Nino

[SOLVED] Find old software

Hello, Thank you for your inquiry. Older versions are only provided on request. You can request them at info(at)segger.com Make sure to explain your situation why you need such an old software. This thread will be closed now. Best regards, Nino

Friday, February 16th 2018, 2:47pm

Author: SEGGER - Nino

STM32F411RE - Timeout while checking target RAM

Hello Krzysztof, Try connecting the reset pin as well to J-Link. Generally it is recommended to connect the reset Pin to J-Link to have a fallback if software reset is not enough on the used target device. If it still does not work compare the eval board schematic with your custom board schematic and see if there are any other differences. Best regards, Nino

Friday, February 16th 2018, 2:32pm

Author: SEGGER - Nino

Cannot use JLinkRemoteServer on linux from windows' Keil: Max. number of connections exceeded.

Hello, Thank you for your inquiry. Such an issue is not known to us. How is your exact setup? Is the Linux box int he same network as the Windows PC? Or are you using the RemoteServer in tunneling mode to a remote location? Does the connect generally work when using J-Link commander? Should your setup be in the same company network we suggest the usage of a J-Link PRO over Ethernet so no timing problems appear. Best regards, Nino

Friday, February 16th 2018, 1:48pm

Author: SEGGER - Nino

JLink & ATSAMB11

Hello Efthymios, we received the SAMB11 eval boards from Microchip for testing. The eval boards are named ATSAMB11-XPRO. Attached is the commander output of a testhaltgo. Everything is working as expected when selecting Cortex-M0. So it seems that this issue is not related to J-Link. We suspect your debug connection is somewhat different to the expected design or the debug cable is unreliable. Compare the schematics of the SAMB11 eval board to your custom design and find out what the differences...

Friday, February 16th 2018, 10:52am

Author: SEGGER - Nino

[SOLVED] j-link do not erase or program device STM32F103 in long JTAG chain

Hi Vsevolod, Great to hear that you are up and running again. We will consider this case as closed now. Best regards, Nino

Friday, February 16th 2018, 9:07am

Author: SEGGER - Nino

Link Errors - Undefined References When Importing from IAR

Hello Mike, We received your request per e-mail as well. Please do not open several communication channels at the same time to avoid information getting lost. That way it only takes longer for us to answer. The question will be handled per e-mail further. This thread will be closed now. Best regards, Nino