Saturday, February 24th 2018, 4:51am UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 87.

Tuesday, February 13th 2018, 12:18pm

Author: v01d

Getting output from user actions in Ozone

Does this mean you cannot get output of those commands in Ozone 's console .. ? (Same as with JLink commander : read memory, it prints output ). Did not plan to log anything ..

Sunday, February 11th 2018, 11:06am

Author: v01d

How to chain multiple Post-Link commands

I would like to have more than one post link command, in SES. I can of course replace the one default to invoke my script say. But I wonder if you can do this in SES without custom script. So in project settings, User Build Steps, Post-Link Command I would like to replace with 2 in 1 as: "$(ToolChainDir)/arm-none-eabi-objcopy" -Oihex "$(RelTargetPath)" "$(PostLinkOutputFilePath)".hex ; "$(ToolChainDir)/arm-none-eabi-objcopy" -v -Obinary "$(RelTargetPath)" "$(PostLinkOutputFilePath)".bin But the ...

Sunday, February 11th 2018, 6:55am

Author: v01d

Getting output from user actions in Ozone

Is it possible to get the output of the User Actions command inside Ozone? E.g. I do Target.ReadU32( 0x80000004) . When I do this from Ozone's Console window, command seems runs, but I get no output. Is there special window .. ?

Sunday, February 11th 2018, 4:29am

Author: v01d

Folder refresh or sync

Is there a way to set folder to sync or refresh with filesystem periodically? E.g. : "Output Files" folder may say have a hex file in it. If i delete it on the filesystem, that folder in SES still has it, and double clicking on it generates an error but does not remove the artifact. I see no folder refresh or reload, or file reload. (Eclipse has Refresh / F5 quite handy for this ..)

Saturday, February 10th 2018, 10:53am

Author: v01d

Specifying include path using SES folder

It would be nice if you could specify include path using the SES folder you create. Which then magically resolves to correct include path (or paths, depending on folder) when building. It would be nice to be able to reference file (=folder) path using the dynamic macros. E.g. create SES folder "my_folder", which may map to some folder on file system. And then if you could use a marco such as $(my_folder) which resolves to correct file system path(s).

Saturday, February 10th 2018, 10:45am

Author: v01d

Setting build options per file

It seems not possible to set build options / compile options per-file ? It doesn't even seem possible to set it per folder - either dynamic or not. (I feel this is a disadvantage relative to Eclipse).

Friday, February 9th 2018, 11:20am

Author: v01d

JLINK GDB and ARM MCU Eclipse for MX7D M4

Quoted from "LHE" On trying the same test while connected to the M4 i simply get "WARNING: CPU could not be halted". Well helloouu there, friend. Just a quick question: do you know that M4 is enabled & running before you connecting to it and trying to halt?

Friday, February 9th 2018, 9:03am

Author: v01d

Using alternative GCC/binutils with SES

Oh wow ... Looks like they not using GCC front end, Segger has it's own. (Is this unfortunate, or ?) Quoted In SES the compiler is called by cc1 markuskrug, that's the backend .. U dunno, I would be feeling better if it would be possible to use GCC front end, but .. I''ll see what they reply. Edit: So I gave it a quick try building external and note: 1) Tool Chain Directory was the only thing I had to change. Note, I tried GNU ARM v 6, and v7 latest . On sample project Hello only. 2) Unlike the ...

Sunday, February 4th 2018, 6:12am

Author: v01d

systemview systemview-2.52.1.x86_64.rpm is a broken install

libQTGui from latest jlink (jlink-6.30.1-1.x86_64) /ozone package doesn't work, but the libQT files included in ozone-ubuntu-2.30.4.x86_64.rpm work (SystemView starts )

Sunday, February 4th 2018, 3:05am

Author: v01d

systemview systemview-2.52.1.x86_64.rpm is a broken install

After (successfully) installing systemview-2.52.1.x86_64.rpm, application won't run because: SystemView: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory (This library seems included in JLink & ozone installation packages, unlike ..)

Wednesday, December 20th 2017, 4:08am

Author: v01d

[ABANDONED] uploading & debugging Externally Built Executable project

Quoted Where did you specify the bin file? Project Options -> Debug -> Loader -> Load file I spec'ed complete path to the externally built *bin file Quoted Where did you specify the bin file? Project Options -> Debug -> Loader -> Load File Address I put the address I want to load this to (as posted originally, in DDR , tested 0x80000000 or 0x87800000, depending on build) Quoted When did it ask you for an address? It only asked if I left "Load File address" field (see above) empty. This was firs...

Wednesday, December 20th 2017, 3:02am

Author: v01d

[SOLVED] How to read iMX7's MDM-DAP registers with JLink

Thanks Nino for the information. I will need to spend some time checking this, if I find something that will fix it for me I will report here.

Wednesday, December 20th 2017, 2:52am

Author: v01d

[SOLVED] JLinkExe's RSetType stopped working

Quoted from "SEGGER - Nino" Hi, The issue was reproducible with your sample. The statement: if (0 == MAIN_ResetType) can't be parsed correctly. Instead use MAIN_ResetType == 0. Then everything should be working as expected. We discuss internally if the parser will be expanded to support that order as well. Quoted The RSetType and my script used to work in version(s) before 6.20i Could you specify with what version it worked how you posted it? Because the script file parser has not been changed ...

Wednesday, December 20th 2017, 2:37am

Author: v01d

[ABANDONED] uploading & debugging Externally Built Executable project

Hi, Quoted Keep in mind that this is *not* a support forum. Yes, I was told multiple times, so I acknowledge I was informed about it. I didn't find I'm overusing or abusing the forum. However, I''ll note that me/we in process of deciding if we will pay for ES license(s), so trying to save time getting all setup with ES to see it does all needed. I'll get back to your questions on my actual question in a flash after I checked it.

Wednesday, December 20th 2017, 2:28am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

Hi, Thanks for replying Quoted Please familiarize yourself with the documentation of our products before opening numerous threads. This is my first Ozone related thread. Which other "numerous" ozone related thread you refer to? Quoted Now back to topic. Yes please stick to the topic rather, than complaining about me asking questions? Thank you for the useful part of that reply which I will try asap, no information passed will be wasted.

Tuesday, December 19th 2017, 1:42am

Author: v01d

[ABANDONED] uploading & debugging Externally Built Executable project

Any update, Nino? With Eclipse, I was able to do this within 5 minutes. Please provide some steps to do this with ES.

Tuesday, December 19th 2017, 1:41am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

Quoted from "SEGGER - Nino" Hello, This is also possible in Ozone. It is described in detail in the Ozone user manual in chapters 6 and 7.7/7.8. There you will find all options and combinations of downloading files and loading the according elf files and other options as well. Best regards, Nino Chapter 6 is Scripting interface, and 7 is Appendix , 7.7 Action Tables, 7.8 User Actions. Which one deals specifically with loading first a bin image followed by symbols? Do you have example? Chapter 5...

Sunday, December 17th 2017, 1:16am

Author: v01d

[SOLVED] How to read iMX7's MDM-DAP registers with JLink

Hi, The silent fail behavior also repeats for a bunch of other (because I only tried few, possibly many more) registers when system runs. For the target in question, connected to A7_0 core, but before Linux has booted, you can access with JLink registers or SRC_A7RCR0 and SRS_M4RCR, for example. JLinkExe works and reads and writes. If you try access same registers after Linux has booted, (even after re-connect with JLinkExe), reading those registers silently fails.. (again no message of an sort)...

Sunday, December 17th 2017, 12:46am

Author: v01d

[SOLVED] how to add symbols file to Ozone when loaded bin

I'm trying to load a *.bin file built with external system, it is the one to be debugged, to be loaded at address specified by me. I want to use symbols file to be loaded separately. (this is to do with how it was built). For example, this setup is possible with DS-5 studio: you can load bin, specify symbols file from an elf later, and then also trigger re-load symbols at offset, they have console for this Which is all handy for a self-relocating code