Tuesday, April 24th 2018, 6:31pm UTC+2

You are not logged in.

  • Login
  • Register

Search results

Search results 1-4 of 4.

Thursday, February 15th 2018, 2:32pm

Author: sevkins

[SOLVED] j-link do not erase or program device STM32F103 in long JTAG chain

Ok, i`ve done all you wrote. Let`s have a little check, my JLinkSettings script is in attachments. But there is still a mistake (actually another one). I attached a log file with my programming. UPDATE Sorry, seems to be a mistake in previous JLinkSettings. The actual one is here: JLINK_SYS_Report("J-Link script file: Manually configuring JTAG chain"); JLINK_JTAG_SetDeviceId(0, 0x3BA00477); // IRLen: 4 JLINK_JTAG_SetDeviceId(1, 0x16410041); // IRLen: 5 JLINK_JTAG_SetDeviceId(2, 0x1E9041CF); // I...

Thursday, February 15th 2018, 9:35am

Author: sevkins

[SOLVED] j-link do not erase or program device STM32F103 in long JTAG chain

Hello Nino, thanks for answering. Here in the attachments are screen shot for connecting to second STM32 device and a log file you`ve asked.

Monday, February 12th 2018, 4:48pm

Author: sevkins

[SOLVED] j-link do not erase or program device STM32F103 in long JTAG chain

Greetings! I have a device with long JTAG chain (one STM32f103, then two different PLD`s, then other STM32F103). I need to program a last one STM32. I used a ULINK2 for this and are trying to move forward to J-Link (Base version). You can have a look at the chain in attachments. I`m trying to program the controller with KEIL mVision 5.24 + J-Link HW 10.10 and dll 6.30b. mVision prints Build Output like this: ------------ DLL: V6.30b, compiled Feb 2 2018 18:36:54 Firmware: J-Link V10 compiled Feb...