Sunday, June 25th 2017, 9:13am UTC+2

You are not logged in.

  • Login
  • Register

Kenny

Beginner

Date of registration: Jul 17th 2008

Posts: 70

Location: San Francisco Bay Area

Occupation: Embedded Systems Engineer

1

Friday, July 29th 2016, 10:37pm

Remove JLinkMem Dependency

Is it possible to remove this dependency?

1> Library/libos_v7m_t_vfpv4_le_dp.a(RTOS.o): In function `OS_SetPRIMASK':
1> (.text+0x138): undefined reference to `OS_JLINKMEM_BufferSize'

Thanks,

Kenny

Kenny

Beginner

Date of registration: Jul 17th 2008

Posts: 70

Location: San Francisco Bay Area

Occupation: Embedded Systems Engineer

2

Friday, July 29th 2016, 10:37pm

Nice emoji buried in there.

SEGGER - Til

Super Moderator

Date of registration: Nov 14th 2007

Posts: 250

3

Monday, August 1st 2016, 8:46am

Hi Kenny,

OS_SetPRIMASK() does not use OS_JLINKMEM_BufferSize at all.
Did you get this as a linker error message?
You can completey remove OS_JLINKMEM_BufferSize only with the embOS source version but if you don't want to use the J-Link Buffer you can just disable the embOSView communication in the RTOSInit.c
This is already done in the Release configuration.

Please don't hesitate to contact us directly per email.
You can find the embOS support email address in chapter "Support" of the embOS manual.

Best regards,
Til

Kenny

Beginner

Date of registration: Jul 17th 2008

Posts: 70

Location: San Francisco Bay Area

Occupation: Embedded Systems Engineer

4

Tuesday, August 2nd 2016, 12:00am

Hi Til,

Yes. That was a linker error that I posted.

I don't have any code related to EMBOS View in my RTOS integration code only the definition of this variable. Currently I have just set it to zero.

I have the object-code license. In this case is this the best I can do? It seems that the library wants that defined.

SEGGER - Til

Super Moderator

Date of registration: Nov 14th 2007

Posts: 250

5

Tuesday, August 2nd 2016, 8:46am

Hi Kenny,

actually the linker error message is capable of being misunderstood because OS_JLINKMEM_BufferSize is not used in OS_SetPRIMASK() but at other places in the RTOS.asm.
Setting it to zero is the correct solution as long as you have the object code version only.
With the source code version you could remove it completely but that is not necessary.

Please be aware it is not guaranteed that we answer here in a short time (or at all).
Since you have a valid embOS license please use the support email address.
This gives us the chance to answer your questions within a few minutes.

Best regards,
Til