Friday, September 22nd 2017, 7:00pm UTC+2

You are not logged in.

  • Login
  • Register

abraham

Beginner

Date of registration: Jun 12th 2017

Posts: 1

1

Tuesday, June 13th 2017, 8:29pm

[ABANDONED] I cannot program an EFM8 chip from Keil uV5 by means of J-Link EDU

Dear friends,
I need help to identify the reason why I could not flash EFM8LB12F64E (Laser bee, 8051 core) by means of Segger J-Link Edu from Keil uV5


PC : KEIL uVision v5.14.2.1 on Win-10 OS

Board : Custom made board. No problem with Silabs C2 Debugger
.... Project --> Options for Target --> Debug ---> "J-Link / J-Trace EFM8 Driver" SELECTED
.... Project --> Options for Target --> Utilities---> "Use Debug Driver" CHECKED
.... Project --> Options for Target --> Utilities---> "Update Target before Debugging" CHECKED
.... Segger J-Link driver version --> 6.16b
.... Segger J-link functionality --> Checked from command prompt by using jlink commander. The chip EFM8LB12F64E has been erased from command prompt. Jlink can query the EFM8. Following is what I copied from the command prompt screen (Serial number has been replaced by ********* intentionally);
------------------------------------------------------------------
C:\Program Files (x86)\SEGGER\JLink_V616b>jlink
SEGGER J-Link Commander V6.16b (Compiled Jun 9 2017 18:04:04)
DLL version V6.16b, compiled Jun 9 2017 18:03:30
Connecting to J-Link via USB...O.K.
Firmware: J-Link V9 compiled Jun 9 2017 17:27:29
Hardware version: V9.20
S/N: *********
License(s): FlashBP, GDB
OEM: SEGGER-EDU
VTref = 3.270V
Type "connect" to establish a target connection, '?' for help
J-Link>
-------------------------------------------------------------------
I don't see any problem regarding installation, wiring, ... etc. May there be some mismatch between corresponding dll and uVision IDE? dll version is 4.97.11.0 (C:\Keil_v5\C51\BIN\JLinkEFM8.dll)
Also, uVision 5 can connect to MCU in debug mode (ctrl + F5), but, cannot flash it.
Here are the messages in debug mode;
-------------------------------------------------------------------
J-Link info: Device "EFM8LB12F64E" selected.
J-Link info: Device "EFM8LB12F64E" selected.
J-Link info: DevID, DerivID: 0x34, 0x42
J-Link info: Core: CIP-51 (8051 compatible)
J-Link info: Device series: EFM8 series device
J-Link info: CPU supports 4 code breakpoints
J-Link info: Flash infos: 512 byte sectors, 126 sectors
-------------------------------------------------------------------
I can erase and program the chip well from Simplicity Studio 4 (by J-link EDU, of course :) )


Can someone help me?
Best regards!

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,619

2

Wednesday, June 14th 2017, 9:31am

Hi,


Quoted

I can erase and program the chip well from Simplicity Studio 4 (by J-link EDU, of course :) )


Well, that sounds like the hardware and the J-Link EDU are working.
Could you please check which version of the J-Link software is used by Keil MDK uVision in the J-Link control panel, which is open by clicking the J-Link icon in the tray bar during a debug session attempt?


Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link