Thursday, September 21st 2017, 8:48am UTC+2

You are not logged in.

  • Login
  • Register

CWE

Beginner

Date of registration: Apr 26th 2017

Posts: 5

1

Wednesday, June 7th 2017, 1:36pm

[SOLVED] J-Link not found by SWO-Viewer

Hello *,

since updating to 6.16a my J-Link couldn't be found by the SWO-Viewer. All other Software works. Anyone else?

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,611

2

Thursday, June 8th 2017, 9:12am

Hi,


thanks for your inquiry.
We will take a look at this issue.

Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,611

3

Thursday, June 8th 2017, 9:40am

Hi,


We are not able to reproduce this behavior.

Can you please reboot your PC and check again?
If the issue persists, can you please send us a detailed step-by-step instruction of your procedure?
Do you have multiple (application) instances open which have a open connection to the J-Link?

Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,611

4

Thursday, June 8th 2017, 4:39pm

Hi,


Update:
We identified the problem.
It was a SWOViewer specific use-case of the J-Link software.
Will be fixed in the version planned to be released tomorrow evening.

Best regards
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link

CWE

Beginner

Date of registration: Apr 26th 2017

Posts: 5

5

Thursday, June 8th 2017, 4:50pm

OK - thank you. Sometimes I can get it to work but closing the SWO-Viewer completly destroys the conection to the device and my IDE hangs until shuting it down with the Task-manager

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,611

6

Friday, June 23rd 2017, 7:16pm

Hi Forum,


this issue has been fixed in version 6.16c of the J-Link software & documentation pack.


Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link