Sunday, December 17th 2017, 1:37am UTC+1

You are not logged in.

  • Login
  • Register

Date of registration: Nov 6th 2017

Posts: 2

1

Monday, November 6th 2017, 3:13pm

SystemView Integration with uCos III V3.03.01, RTT block not found

Hello all,

I am using Version V3.03.01 uCos_III within a LPC2925 ARM9 processor.
The debugging pod is a J-link base version 9.2. I used the

sample code for uCos_III from your website. I have added the code to the build.



  • I check within RAM memory and
    found "SEGGER RTT" string marking the being of the RTT control block at a
    memory location of 0x8000222c. SystemView should be able to find the
    control block, but doesn't
Sometimes I get " Bad JTAG
communications write to IR: Expected 0x1, got 0x0 Trap Command : 2 @ off
0x9". Other times I just get RTT block not found. I am not sure how to
proceed from here.

I have read the manual several times, but I still can't seem to get
communication between my version of uCos_III and SystemView. I know the
later version of uCos III release in 2016 has already integrated

SystemView in their cod base, but I am using a 2012 release.



Can you give me more informaiton on how the communicaiton flow between
the SystemView Host program an the target? From what I understand,
SystemView first looks for the string "SEGGER RTT" to find the

control block. What does SystemView do next?
edavis@rexa.com has attached the following file:
  • error.bmp (240.14 kB - 35 times downloaded - Last download: Dec 8th 2017, 4:20am)

This post has been edited 2 times, last edit by "edavis@rexa.com" (Nov 6th 2017, 3:41pm)


SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 467

2

Wednesday, November 8th 2017, 10:08am

Hello Earl,

System View continuous recording is not possible on ARM9 cores as RTT is used for that.
So you are limited to single shot recording or post mortem mode with that device.
More information can be found on the SystemView website and the user manual.

Best regards,
Nino

Date of registration: Nov 6th 2017

Posts: 2

3

Monday, November 13th 2017, 4:31pm

Ok, thankyou
I am new to systemview... I tried the single snap shot mode.

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 467

4

Tuesday, November 14th 2017, 4:07pm

Hello Earl,

Quick follow up question.
Is there a particular reason that you are using uCos?
Alternatively we suggest using our own embedded OS called embOS: https://www.segger.com/products/rtos/embos/

Would that be of interest of you?
The benefit would be that all our software and hardware tools are optimized to work perfectly with embOS so it would make sense to take a look if you already are using several of our products.

Best regards,
Nino