Sunday, December 17th 2017, 1:32am UTC+1

You are not logged in.

  • Login
  • Register

taquionbcn

Beginner

Date of registration: Nov 28th 2017

Posts: 3

1

Tuesday, November 28th 2017, 11:30am

Help neeeded making work System viewer with STM32

Hi there,

My currently setup is STM32L476 with J-link EDU 8connected without SWO pin, next board version) would have it.
Since now I have been developing with ozone without problems.

Now I'm using freeRTOS and I would like to see/debug my tasks using system viewer.

There is very little information on how to use it with ST microcontrolles, but I've started with the System Viwer Manual and found the first problem:

at main I have added:

C/C++ Source code

1
#include "SEGGER_SYSVIEW.h"


and inside main()

C/C++ Source code

1
2
3
	SEGGER_SYSVIEW_Conf(); /* Configure and initialize SystemView */

	SEGGER_SYSVIEW_Start();


before creating the freeRTOS task and before running freeRTOS

but after that, when I run it, it gets stuck at port.c (freeRTOS folder) line 752:

C/C++ Source code

1
configASSERT( ( portAIRCR_REG & portPRIORITY_GROUP_MASK ) <= ulMaxPRIGROUPValue );


What I'm missing?
Is mandatory to have the SWO pin connected?
does anyone knows a guide or tutorial for ST mcus?

Thanks,

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 467

2

Monday, December 4th 2017, 11:25am

Hello,

Thank you for your inquiry.

SWO is not needed for Systemview whatsoever. It completely relies on RTT.
There is no STM32 specific description in the manual as all setups for all supported Coretypes is the same.
In the manual under "Supported OSes" you can find how to set up Systemview for FreeRTOS.
To find out why the assert gets called check your callstack where the call came from.

Did you know that we also offer a RTOS which is the world leading OS for embedded devices?
More information can be found here: https://www.segger.com/products/rtos/embos/
With embOS you also don't need to configure Systemview as it runs out of the box.

Best regards,
Nino