Monday, December 11th 2017, 10:14am UTC+1

You are not logged in.

  • Login
  • Register

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 56

1

Thursday, November 30th 2017, 7:04am

[SOLVED] cannot find entry symbol reset_handler...

Wanted to give a quick go at the Embedded Studio.

Created an iMX7/M4 project, with default hello_world. Modified nothing, pressed build. Gives me : cannot find entry symbol reset_handler; not setting start address.
Log says Build failed.



Source code

1
/opt/SEGGER/embedded_studio_330/gcc/arm-none-eabi/bin/ld -X -ereset_handler --omagic -defsym=__vfprintf=__vfprintf_int_nwp -defsym=__vfscanf=__vfscanf_int --fatal-warnings -EL --gc-sections "-T/home/xxx/Documents/SEGGER Embedded Studio Projects/test_1/Output/test_1 Debug Internal/Obj/test_1.ld" -Map "Output/Debug Internal/Exe/test_1.map" -u_vectors -o "Output/Debug Internal/Exe/test_1.elf" --emit-relocs "@/home/xxx/Documents/SEGGER Embedded Studio Projects/test_1/Output/test_1 Debug Internal/Obj/test_1.ind"


Tried to change that to Reset_Handler ( based on startup_ARMCM_GCC.S, as provided), no luck..

Whats the quickest way to try out ES with iMX7 M4.. ? A ready working project .
:S

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 434

2

Thursday, November 30th 2017, 9:08am

Hello,

Thank you for your inquiry.
We were not able to reproduce that behaviour.
Attached is the project that came out of the default project wizard for the imx7d5_m4.
Does that build on your machine?
What OS are you using?
How did you proceed exactly when using the project wizard?

Best regards,
Nino
SEGGER - Nino has attached the following file:
  • IMX7_New.zip (121.98 kB - 10 times downloaded - Last download: Dec 9th 2017, 8:01pm)

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 56

3

Monday, December 4th 2017, 2:00pm

Hello,

I'm using the best OS - Linux. (Fedora flava). :thumbsup:

I will double check on my steps, but I'm quite convinced I'm not dreaming of it's giving me that error.

Is your attached example from Linux version of your IDE?

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 434

4

Monday, December 4th 2017, 2:29pm

Hello,

The example was created on Ubuntu 16.04 with ES 3.30

Fedora does generally work as well.
What Fedora version did you use in particular?

Best regards,
Nino

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 56

5

Wednesday, December 6th 2017, 3:58am

Fedora 24.

Screenshot of failed build attached.
Also, attached export solution file .. (i'm not familiar with those on ES, but hopefully contains project setup).

Also, I've downloaded your solution file, and the project builds. I don't understand why, I checked the target is same, and the example seems same.

Which version of ES you using, and which 'project template' do you select when creating the project? I selected "A C/C++ executable for Cortex-M processor (internal tools and external GNU tools)",
and I think you chose "A C/C++ executable for Cortex-M processor". I've tried that, and then I can reproduce what you said, successful build.

If I look into Help of ES, "external" means, not built by ES internal build process. (like external cmake or smth..?) (Btw, "internal" build process uses GCC & GNU make, is that correct?)
Also note in my tests I'm testing build "Debug Internal" configuration, so that should be == as the other template / one that builds (one you used I presume?)

(Sorry for multiple edits of my reply..)
v01d has attached the following image:
  • sigger_es_imx7dm4_prj_build_error.png
v01d has attached the following file:
  • test_1.emArch.7z (21.7 kB - 6 times downloaded - Last download: Dec 9th 2017, 6:07pm)

This post has been edited 5 times, last edit by "v01d" (Dec 6th 2017, 4:38am)


SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 434

6

Wednesday, December 6th 2017, 9:58am

Hello,

How exactly did you proceed step by step when creating the project?
From the file your provided all solution settings are missing.
Attached is the project when i do the following:
File->New Project->Create the project in a new solution->A C/C++ executable for ARM/CortexA/R-processor (internal tools and external GNU tools)->MCIMX7D5_M4->here you can now define an external toolchain you want to use, for my example I simply pressed next without changing anything->Next->Next->Finish

Now "Debug External" is selected by default. In my case this did not build as I entered a wrong path for an external toolchain.
Switch that setting to "Debug Internal".
Now you should be able to build.

How does the project look like when you follow the steps i provided?
If it still does not build could you zip up your project folder (not emarchive to make sure no data is lost)?

Best regards,
Nino
SEGGER - Nino has attached the following file:

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 56

7

Wednesday, December 6th 2017, 12:17pm

Ah, thats what I did different: I've removed some project configurations I thought of no use ... See the picture attached.
Project attached too.
v01d has attached the following image:
  • segger_es_imx7m4_buildcfgselect_forfailed_build.png
v01d has attached the following file:
  • test_1.7z (39.34 kB - 5 times downloaded - Last download: Yesterday, 8:25am)

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 434

8

Wednesday, December 6th 2017, 1:43pm

Hi,

Ok this makes much more sense now :D
Generally we recommend leaving the default config as it is and only change what is really necessary during developement.
As the original question is answered we will consider this case as closed now.

Best regards,
Nino