Friday, December 15th 2017, 8:46pm UTC+1

You are not logged in.

  • Login
  • Register

ktowers

Beginner

Date of registration: May 10th 2017

Posts: 6

1

Tuesday, December 5th 2017, 6:48pm

Identical source files in Ozone

The Source Files pane in Ozone (v2.54 and older) shows two copies of most files. Some source (.c & .cpp) files have the little 01 10 binary icon beside them. These are the only ones that can have breakpoints set in them. The copies seem to be the source file with no additional value.

Where are these extra copies coming from?

I'm compiling with the Keil toolchain with -g on the compiler command line.

Thanks

Kevin

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 467

2

Wednesday, December 6th 2017, 9:25am

Hello Kevin,

Thank you for your inquiry.
Such an issue is not known to us.
Could you send us your .jdebug file and the .elf file you are trying to debug for reproduction?

Best regards,
Nino

ktowers

Beginner

Date of registration: May 10th 2017

Posts: 6

3

Thursday, December 7th 2017, 12:28am

The files are zipped and attached.

Kevin
ktowers has attached the following file:
  • td3100.7z (427.41 kB - 10 times downloaded - Last download: Dec 13th 2017, 3:38pm)

This post has been edited 2 times, last edit by "ktowers" (Dec 7th 2017, 12:33am)


SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 467

4

Thursday, December 7th 2017, 10:40am

Hi Kevin,

Thank you for providing the files.
We were able to reproduce the behaviour with the provided files.
To be sure where the issue is coming from we would need you to provide us your project (ideally) or at least the uVision project file to get an idea where this double information is coming from.
Could you provide this?
Do you build a library out of sources in your project and the library is being reused somewhere?
This might be a potential sources of this double display of some functions.

Best regards,
Nino