Tuesday, March 20th 2018, 3:25am UTC+1

You are not logged in.

  • Login
  • Register

Date of registration: Feb 23rd 2018

Posts: 1


Tuesday, February 27th 2018, 2:20pm

[Ozone] Forced halt in SVC vector


I am currently using:
- Ozone 2.56c on Linux with the JLink DLLs 6.30d;
- TMS570LC4357 on the XL2-570LC43(A) development board;
- JTAG @1 MHz with semihosting Off and RTT Off;
- No custom JLink scripts;

I have an issue where from time to time I am having problems whenever the ARM assembly "SVC #" instruction is called. Whenever I reset and continue, Ozone will break at 0x08 (ARM SVC vector) even if I didn't put a breakpoint there.

I've read that Semihosting uses the SVC location in order to work. I've tried to enable/disabling semihosting and reconfigure semihosting to use another memory location with "Project.SetSemihosting" and "Project.ConfigSemihosting" without any change.

I've also tried:
- Using JLink DLLs 6.30e
- Changing JTAG speed
- Adding/removing breakpoints
- Disconnect, Reconnect to target
- Using Windows

If I continuosly reset and continue I eventually manage to continue,sometimes, without breaking at the SVC, but it's rather rare.

I've produced a simple assembly example where I just use the SVC assembly instruction and NOPs in TI Code Composer Studio. I've attached Code Composer Studio project files, Ozone project files and the binary to this thread.

As a note, the problem doesn't subsist if I use the embedded TI XDS110 debugger present on board.

Could you please point me in the right direction on why this happens and how I can fix it?

Thanks in advance!

alex.gasbarroni has attached the following image:
  • invisible_svc_break.png
alex.gasbarroni has attached the following file:
  • svc_example.zip (22.84 kB - 24 times downloaded - Last download: Mar 17th 2018, 7:10am)


Super Moderator

Date of registration: Jan 2nd 2017

Posts: 817


Friday, March 2nd 2018, 3:26pm

Hello Alessandro,

Thank you for providing the example project.
The issue was reproducible and we are currently working on a fix for this.

Best regards,