Wednesday, May 23rd 2018, 10:29pm UTC+2

You are not logged in.

  • Login
  • Register



Date of registration: Oct 30th 2014

Posts: 1


Monday, November 3rd 2014, 5:55pm

jLink Basic --- How to revert to a previous version of firmware?

We were using Keil uV 5.10.2 and recently tried upgrading to 5.12 where I was asked to up date the jLink firmware. The previous version was dated (11/25/13 (not sure of version number) and updated to 4.92 (dated 9/22/14). After doing so I had lot's of stability problems. The overall IDE worked, but the connection to jLink would get lost, or hung requiring the emulator mode (but not the full IDE) to be restarted several times to get it to actually run. Seems like it'll get a little farther each time it's restarted until it's usable. Needless to say this is very annoying. I reverted the Keil uV back to 5.10.2 and it did not resolve the issue. I also tried another jLink with the older FW with the uV 5.12, it has other issues that prevent it from working. I have no intention of updating any more of our jLinks (we have 5).

So... How do I revert the FW to an older version so I don't have to scrap one of our jLinks?

Were using this with an ADuC7023 if that matters.

Thanks in advance for any help.



Date of registration: Oct 8th 2014

Posts: 3


Wednesday, November 5th 2014, 4:34am

EXEC invalidatefw


Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,516


Monday, November 10th 2014, 7:59pm


more precisely:
UM08001 (J-Link User Guide), chapter "11.5.2 Invalidating the firmware"
Note that you are doing this on your own risk.
No support is given, in case you are running into a problem with an old firmware that does not show up with a current one.

- Alex