Thursday, August 17th 2017, 3:37pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tsmith2456

Beginner

Date of registration: May 13th 2008

Posts: 2

1

Tuesday, May 13th 2008, 3:21pm

IAR V4.30A and various flavours of j-link

We have several flavours of j-link (serial number 00003514 with no hardware version number, a version 5.2 and a version6.0). We downloaded V3.80C DLL etc and found that IAR V4.30A could no longer debug. Even after uninstalling V3.80 of the j-link software the 2 newer versions of hardware would no longer work. We have had to manually reinstall the original IAR 4.30A drivers and point the USB driver at these. Even then only the oldest now works. Has anyone else had issues with the latest j-link software and V4.30A?

SEGGER - Alex

Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,507

2

Wednesday, May 14th 2008, 12:39pm

Hello tsmith2456,

I have tested different hardware versions of J-Link with IAR V4.30A and J-Link software version V3.80c, but I can not see a problem.
J-Link hardware versions used for testing: V5.0, V5.2, V5.4, V6.0
J-Link software version used for testing: V3.80c
Target hardware for testing: Atmel AT91SAM7S-EK (AT91SAM7S256)
Project for testing: Sample project delivered with IAR Embedded Workbench (AT91SAM7S-BasicTools)

Can you please send an e-mail to support@segger.com, including the following information (in a zip file):

A detailed description of the problem
JLink.exe output (screenshot)
J-Link logfile which shows the problem
IAR project to reproduce the problem

Best regards,
Alex

Date of registration: Jul 17th 2009

Posts: 1

3

Friday, July 17th 2009, 3:42am

IAR EWARM v4.41 and j-link drivers

Also have a driver issue with IAR EWARM and J-Link


I have been using IAR EWARM v4.41 for a while now, with the j-link arm over USB with no problems.

Recently I tried to do a debug session and IAR (actually the j-link driver) popped up a message about not being able to connect:

J-Link Driver

FATAL ERROR

Can not connect to J-Link via USB.



On further research I found that somehow the driver had been updated automatically, from the version

that came with the IAR v4.41 (which was driver v2.42) to a newer version of driver (v2.60).

Once I was able to get v2.42 driver back in place, it worked fine again.



Today, once again, it seems to have automatically updated the driver to 2.60, causing the problem again.

I fixed it the same way, but was wondering if there is a more permanent fix, or newer driver to avoid this happening again.



Jason