Monday, December 11th 2017, 11:45pm UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tds

Beginner

Date of registration: May 18th 2015

Posts: 2

1

Thursday, May 28th 2015, 10:50pm

[SOLVED] J-Link DLL Update Renesas e2Studio

I'm using a J-Link Ultra+ with the Renesas e2Studio. I"ve downloaded and installed the latest J-link software (currently 4.98e) and I"m able to use the toolset.

When I connect to the J-Link through the e2Studio, it is still using the 4.84a DLL that shipped with the e2Studio. If I run the J-Link DLL Updater, it doesn't list e2Studio as something that can be updated.

Is it ok to simply drop the new J-LInk driver into the e2Studio install to update?

SEGGER - Erik

Super Moderator

Date of registration: Dec 20th 2011

Posts: 392

2

Monday, June 1st 2015, 9:57am

Hi,

The J-Link DLL updated does not support e2Studio so far. We added "installation detection for e2Studio" to our internal ToDo list but so far without any fixed time schedule.

Quoted

Is it ok to simply drop the new J-LInk driver into the e2Studio install to update?
Yes. You can check the location of the used J-Link DLL by opening the J-Link Control Panel (small green icon in the windows task bar during a debug session in e2Studio is active) --> General tab --> DLL


- Erik

Toni

Beginner

Date of registration: Feb 18th 2015

Posts: 6

3

Thursday, June 25th 2015, 1:58pm

Renesas e2Studio

Hi,

hi have replaced these files:
C:\Renesas\e2_studio\DebugComp\ARM\Segger\JLinkARM.dll

C:\Renesas\e2_studio\DebugComp\JLink_ARM\JLinkARM.dll
C:\Renesas\e2_studio\DebugComp\JLink_ARM\(other files inside this dir)

and the location of the used J-Link DLL is now showng correct value V498e

please tds if you plan to use the V500x version of dll send me a feedback, i have problems with this version with e2studio, only the V498e work for me.

Toni.

tds

Beginner

Date of registration: May 18th 2015

Posts: 2

4

Thursday, June 25th 2015, 11:35pm

I'm successfully using 5.00c with e2Studio 4.x for an RX63N.

I copy JLinkARM.dll from C:\Program Files (x86)\SEGGER\JLink_V500c
to C:\Renesas\e2_studio4\DebugComp\RX\Segger. I then rename JLinkARM.dll to JLink.dll.

Hope that helps.

SEGGER - Erik

Super Moderator

Date of registration: Dec 20th 2011

Posts: 392

5

Wednesday, July 1st 2015, 9:46am

@Toni Do you still see any issues or can we consider this thread as solved?

- Erik

Toni

Beginner

Date of registration: Feb 18th 2015

Posts: 6

6

Wednesday, July 15th 2015, 6:06pm

I have tested today the v500i and is working with a good speed improvement, see attached images,
just one minor issue: with v498e from jlink commander was possible to erase the flash with command erase:

J-Link>erase
Erasing device (R7S721001)...
Info: J-Link: Flash download: Total time needed: 150.412s (Prepare: 3.187s, Compare: 0.000s, Erase: 144.718s, Program: 0
.000s, Verify: 0.000s, Restore: 2.505s)
Erasing done.
J-Link>


now with the v500i the command does nothing:

J-Link>erase
Erasing device (R7S721001)...
Erasing done.
J-Link>





Toni.

SEGGER - Erik

Super Moderator

Date of registration: Dec 20th 2011

Posts: 392

7

Wednesday, July 15th 2015, 6:23pm

Hi Toni,

Thank you for the positive feedback!

Quoted

just one minor issue: with v498e from jlink commander was possible to erase the flash with command erase:
In the old version, flash programming was support for one specific QSPI flash only. Versions >= 5.00 uses the generic QSPI flash programming support which allows to program any cummon QSPI flash conencted to the R7S721001. As customers may connect any peripheral to the SPI pins (they are not forced to use them for the QSPI flash), we are not allowed to toggle the QSPI pins in order to determine if a flash is connected and if so which type / size.

Anyhow, we have already on our ToDo list to add a command which allows customers to explicitly enable erase for particular flash banks. Unfortunately, I can not provide any fixed time schedule for this right now as we are busy with some other projects.


Best regards
Erik