Thursday, August 17th 2017, 3:40pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

mwb1100

Beginner

Date of registration: Sep 30th 2009

Posts: 27

1

Friday, June 10th 2016, 1:04am

[Segger Ozone] embosPlugin.dll

I have started looking at the Ozone debugger, and I am using Ozone with an existing project built with IAR Workbench 5.20. First of all, I was pleasantly surprised that Ozone understood the IAR generated symbols (then again - I don't know if IAR's symbol format is based on GDB's or what).

But when I tried to use the embosPlugin.dll, the "Threads" window doesn't show any of the tasks. This feature does work fine in IAR 5.20 with the IAR embosPlugin.dll I have installed there. I am wondering if the problem I see in Ozone is due to the age of embOS that I am using - version 3.60d. Should the Ozone embosPlugin.dll work with this embOS version?

SEGGER - Johannes

Super Moderator

Date of registration: Aug 31st 2012

Posts: 352

2

Monday, June 13th 2016, 10:39am

Hi,

IAR generated files are, like most files, in the ELF/DWARF format which Ozone can understand.

Unfortunately the embOS plugin does not work with your version of embOS,
you would have to update to a current version of embOS.

Regards
Johannes

Similar threads