Saturday, December 16th 2017, 4:33am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

singhsi

Beginner

Date of registration: Jul 11th 2016

Posts: 2

Location: Noida

Occupation: Technical Expert

1

Monday, July 11th 2016, 10:32am

embosview not working

I am trying to connect embosview using J-Link via USB interface. But I am not able to see any data on GUI although I am seeing the packets exchange in embosview GUI
(As attached).

Can you please help me to setup the embosview with my target device.

Following are my configurations:
J-Link Version 4.4

target Device :
ATMEL - AT91SAM9CN12

Data Sheet : http://www.atmel.com/Images/atmel-11063-…2_datasheet.pdf
singhsi has attached the following images:
  • embosview.jpg
  • J-link conf.jpg

SEGGER - Til

Super Moderator

Date of registration: Nov 14th 2007

Posts: 261

2

Monday, July 11th 2016, 10:57am

HI,

could you please give some basic information?
1. Which embOS and which embOS version are you using?
2. Are you using an embOS start project? Which one?
3. Please ensure in the General Tab "Do not communicate" is not checked

Could you also please check in the according RTOSInit.c if any data is received (_DCC_OnRx())?

Best regards,
Til

singhsi

Beginner

Date of registration: Jul 11th 2016

Posts: 2

Location: Noida

Occupation: Technical Expert

3

Monday, July 11th 2016, 12:17pm

Hi Til,

Thanks for your support. It is working now.

Actually in RTOSinit file , support of DCC was disabled.

#define OS_VIEW_USE_UART 1

#define OS_USE_DCC 0



After enabling the DCC , I am able to see all the relevant information in emboSview GUI.

Regards,
Shobhit

SEGGER - Til

Super Moderator

Date of registration: Nov 14th 2007

Posts: 261

4

Monday, July 11th 2016, 1:18pm

Hi Shobhit,

thanks for your feedback.
As long as you are in embOS support you can also contact us directly by the embOS support email address.

Best regards,
Til