Thursday, June 29th 2017, 9:20am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Date of registration: Jan 3rd 2013

Posts: 5

1

Thursday, May 25th 2017, 1:28pm

Simulation & trial version v5.40 in vs2017

Can i run emwin simulation&trial version v5.40 in visual studio 2017 community without any other configuration? ı want to developed all screen in simulation without real lcd and board :?:

SEGGER - Schoenen

Super Moderator

Date of registration: Aug 13th 2015

Posts: 309

2

Thursday, June 1st 2017, 5:01pm

Hi,

Of course you can.

The problem is that we have set up the project for VS2010 and want to keep it in that format for a while. This allows users with VS2010 to use the simulation, too.

For those using a newer version of Visual Studio follow these steps to run the simulation:

1. Right-Click on the Project (e.g. SimulationTrial) -> Properties
2 Set Configuration to "All Configurations"
3. Goto Configuration Properties -> Linker -> Input.
4. Add under Additional Dependencies: "legacy_stdio_definitions.lib"
5. Set Ignore All Default Libraries: "No"
6. Set Ignore Specific Default Libraries: "LIBC.lib;LIBCMTD.lib"
7. Goto Configuration Properties -> Linker -> Advanced
8. Set Image Has Safe Exception Handlers:"No (/SAFESEH:NO)"
9. Click "OK"-Button.

Regards,
Sven