Sunday, June 25th 2017, 2:04am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

rene.becker

Beginner

Date of registration: Nov 14th 2013

Posts: 5

1

Tuesday, May 30th 2017, 3:29pm

SystemViewer can't find RTT Control Block unless debug session is in progress

Hello,

I believe that with SystemViewer I should be able to connect to a running target at any time, but at the moment I am not able to do so unless I have an active debug session going. When a debug session is runnig SystemView appears to work as it should, if not I always get an error message "Failed to start recording. RTT Control Block not found".

The device I am working with is a TI Stellaris LM3S2D93, I am using Code Composer Studio V6.2. I am using the gcc toolchain, not TI's toolchain.

Any ideas?

Thanks in advance,
Rene

rigomate

Beginner

Date of registration: Sep 5th 2014

Posts: 18

2

Tuesday, June 13th 2017, 3:43pm

I am just curious: What happens if you specify the control block address manually, will it work then ?

rene.becker

Beginner

Date of registration: Nov 14th 2013

Posts: 5

3

Wednesday, June 14th 2017, 6:57am

Ok, it's working.

By default the 'Configuration' Dialog that pops up when pressing the green arrow button shows Cortex-M3.
If I go and expand the drop down list I find the actual device (LM3S2D93) in the list, and after selecting that SystemView connects just fine.

I didn't look there before because I thought Cortex-M3 was auto-detected correctly (and the device indeed is based on a Cortex M3 ...

I am also having trouble with some other aspects, e.g. I cannot use plain Eclipse with GNU Arm Eclipse plug ins to program/debug (debug session seems to start normal, but after some experimenting I found that the program download was not performed properly) and when I use 'loadfile' with a J-Link commander session the command appears to get silently ignored (i.e. program is not loaded). Looks as if there are some special procedures required to communicate with this device ....

Regards,
Rene

SEGGER - Johannes

Super Moderator

Date of registration: Aug 31st 2012

Posts: 350

4

Wednesday, June 21st 2017, 3:15pm

Hi,

If you select just a generic core, such as Cortex-M3, J-Link will usually be able to connect to your device.
But to auto-detect the RTT Control Block, J-Link needs to know where the RAM is located.

Therefore you need to either select your specific device (recommended) or specify the control block address or search range.

For flash programming the same applies, the J-Link needs to know which device it is connected to.
And for some devices special handling is necessary.

So overall it is always recommended to specify the connected device instead of just the core.

Best regards
Johannes

rene.becker

Beginner

Date of registration: Nov 14th 2013

Posts: 5

5

Friday, June 23rd 2017, 2:54am

Thanks, Johannes.

makes sense.

Have just tried standard Eclipse with Gnu ARM Eclipse plugin again, this time specifying the exact part number.
Unfortunately still not working.

I am using TIs code composer at the moment which is ok, but it does not appear to support the remote debugging feature.
No problem during development, but when deploying remote debugging would be a really good feature to have ...

Regards,
Rene