Tuesday, August 22nd 2017, 1:38am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

smithk726

Beginner

Date of registration: Jun 30th 2016

Posts: 3

1

Friday, June 9th 2017, 9:01pm

[SOLVED] Error while identifying Cortex-M device

I have the error mentioned above.
Below is the log from JLink.exe - connect.
C:\Program Files (x86)\SEGGER\JLink_V512i>JLink
SEGGER J-Link Commander V5.12i (Compiled Jul 5 2016 19:02:32)
DLL version V5.12i, compiled Jul 5 2016 19:01:50
Connecting to J-Link via USB...O.K.
Firmware: J-Link ARM V8 compiled Nov 28 2014 13:44:46
Hardware version: V8.00
S/N: 158007855
OEM: IAR
VTref = 3.293V

Type "connect" to establish a target connection, '?' for help
J-Link>connect
Please specify device / core. <Default>: TM4C123GH6PM
Type '?' for selection dialog
Device>
Please specify target interface:
J) JTAG (Default)
S) SWD
TIF>
Device position in JTAG chain (IRPre,DRPre) <Default>: -1,-1 => Auto-detect
JTAGConf>
Specify target interface speed [kHz]. <Default>: 4000 kHz
Speed>
Device "TM4C123GH6PM" selected.

TotalIRLen = 4, IRPrint = 0x01
TotalIRLen = 4, IRPrint = 0x01
****** Error: Error while identifying Cortex-M device
TotalIRLen = 4, IRPrint = 0x01
TotalIRLen = 4, IRPrint = 0x01
Cannot connect to target.
J-Link>
The board the JLink is connected to starts up on its own and runs the program already flashed.
This board has worked with this JLink device for many weeks.
When the above error is reported, the board resets.
What do I do to correct this problem?
Keith Smith

smithk726

Beginner

Date of registration: Jun 30th 2016

Posts: 3

2

Friday, June 9th 2017, 11:23pm

Problem corrected by rebooting PC.

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,569

3

Monday, June 12th 2017, 9:38am

Hi,


thanks for the update and good to hear that you are up and running again!


Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link