Sunday, February 18th 2018, 9:59am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

donturner

Beginner

Date of registration: Jul 15th 2016

Posts: 14

1

Friday, July 7th 2017, 12:11pm

[SOLVED] Why doesn't flashing OpenSDA firmware work on OSX?

I have a brand new FRDM-KL25Z board. It ships with an OpenSDA firmware which is compatible with a P&E debugger. I tried to replace the firmware with one from SEGGER using my Macbook Pro running OS X 10.12.5.

Here's the steps I went through:

- Hold down the reset button on the FRDM board and connect to OSX via USB
- Board appears as "BOOTLOADER" drive
- Copy the 12_OpenSDA_FRDM-KL25Z.bin onto the root of this drive
- Unplug the FRDM board and plug it back in

What happened:

- Nothing - the board has the original P&E firmware on it.

When I try the exact same steps on a Windows10 machine the firmware is updated successfully and I can connect via J-Link.

Why doesn't firmware flashing work on OSX?

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,691

2

Friday, July 7th 2017, 7:12pm

Hi,

This is a limitation of the OpenSDA bootloader, which can not be lifted by SEGGER.

Please note that it is explicitly mentioned on the website that OpenSDA firmware flashing is not supported on macOS.
https://www.segger.com/products/debug-pr…opensda-sda-v2/


Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link