Monday, December 11th 2017, 10:18am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Date of registration: Nov 10th 2017

Posts: 1

1

Friday, November 10th 2017, 4:27pm

[BUG?] [workaround] SES v3.30 hangs on startup when source control exe path set incorrectly

Reproduction
SES v3.30
0. one instance of SES opened with a project using git source control
1. settings-> source control -> git exe set to git-cmd.exe (the correct would be git.exe)
2. close SES
3. start SES, hangs before project files are shown

Symptoms
Unable to change settings to fix the problem due to SES hang

Possible solution
don't allow selection of incorrect git.exe

workaround
0. force close SES
1. remove reference to incorrect executable in 'C:\Users\[username]\AppData\Local\SEGGER\SEGGER Embedded Studio\v3\settings.xml'
2. start SES and set correct executable

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 434

2

Monday, November 13th 2017, 9:13am

Hello,

What exactly is the question?
If you have troubles setting up version control in ES we recommend the following wiki article: https://wiki.segger.com/Embedded_Studio_VCS_configuration

Best regards,
Nino