Monday, December 11th 2017, 4:59am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

katiki

Beginner

Date of registration: Nov 29th 2017

Posts: 1

1

Wednesday, November 29th 2017, 2:49pm

JLink on Debian Jessie: Connecting to J-Link via USB...FAILED: Cannot connect to J-Link via USB

Hi all,

I have purchased a JLink / JTAG Emulator USB for flashing to embedded devices.
Unitl now, everything works fine on Windows 7.
But as we're mostly working on Linux, I planned to port my scripts to Linux.

The Host Linux is a Debian Jessie 8 (x64), and so I've downloaded the latest versions of JLink (6.16 and today 6.22).
But as I launch JLinkExe, I desperately get the message Connecting to J-Link via USB...FAILED: Cannot connect to J-Link via USB
I tried to install the i386 version and then the x86_64, I tried to change the USB ports, I checked the cables, I tried under "root" user and my own user...same error. ;(

So. I have no more idea.
Any help / suggestion would be highly appreciated.

Thanks.

Best Regards,

Karim

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 430

2

Wednesday, November 29th 2017, 3:22pm

Hello Karim,

Thank you for your inquiry.
The described issue is not known to us.
How did you proceed when installing the J-Link software package on your Linux machine?
Did you follow the instructions in the ReadMe if you installed the software from the .tgz archive?
Are you running Linux in a VM or natively?

Best regards,
Nino