Monday, December 11th 2017, 4:45am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Geoff_S

Beginner

Date of registration: Dec 5th 2017

Posts: 3

1

Wednesday, December 6th 2017, 12:03am

FRDM-KL28Z with current J-Link OpenSDA firmware

I have a new FRDM-KL28Z dev board which comes with the default DAPLink bootloader and OpenSDA v2.2 firmware. I am having problems loading the current J-Link OpenSDA firmware on it. If I power the board up into bootloader mode, copy the latest J-Link firmware (from the "J-Link OpenSDA - Board-Specific Firmwares" page for the FRDM-KL28Z board) on to it, when the board restarts it is still running the original OpenSDA v2.2 firmware and a J-Link debug probe is not available. The best I have been able to do is load the generic J-Link OpenSDA v2.1 firmware (from "J-Link OpenSDA - Generic Firmwares - OpenSDA v2.1" page) which does result in a J-Link debug probe being available.

Am I doing something wrong, or is there a known issue with this board and the latest J-Link firmware ?

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 430

2

Wednesday, December 6th 2017, 9:22am

Hello,

Thank you for your inquiry.

According to our website the board is running open SDA 2.0 : https://www.segger.com/products/debug-pr…-v2/#tab-3932-4
Did you try that?
Other versions are not tested and are not guaranteed to work.

Best regards,
Nino

Geoff_S

Beginner

Date of registration: Dec 5th 2017

Posts: 3

3

Wednesday, December 6th 2017, 1:01pm

No I did not try that version, since the FRDM-KL28Z runs OpenSDA v2.2 as shown on NXP's website https://www.nxp.com/support/developer-re…adapter:OPENSDA

I think perhaps your website is wrong if it is indicating it runs v2.0 ?

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 430

4

Wednesday, December 6th 2017, 1:55pm

Hi,

I think i have to rephrase what i wrote.
The firmware we provide has been tested with a FRDM-KL28Z board that runs open SDA 2.0 and this configuration is working.
Any other configuration is not tested and thus currently not supported.
It might be that newer FRDM-KL28Z board revisions ship with other/newer open SDA versions.

We will see if we can get such a board and add support eventually.

Best regards,
Nino

Geoff_S

Beginner

Date of registration: Dec 5th 2017

Posts: 3

5

Thursday, December 7th 2017, 12:47am

Thanks Nino, that makes sense. I don't think I can downgrade the OpenSDA bootloader to v2.0, but you should be able to upgrade v2.0 to v2.2 using the DAPLink image from mbed website (step 1 on following link)
https://os.mbed.com/blog/entry/DAPLink-bootloader-update/

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 430

6

Thursday, December 7th 2017, 9:40am

Hi,

Quoted

I don't think I can downgrade the OpenSDA bootloader to v2.0, but you should be able to upgrade v2.0 to v2.2 using the DAPLink image from mbed website (step 1 on following link)


Completely understandable. We have a couple of boards here so I will give it a go with one of them.
I will inform you once I have gathered more information.

Best regards,
Nino