Sunday, May 20th 2018, 5:31pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



Date of registration: Jan 22nd 2018

Posts: 7


Wednesday, March 7th 2018, 6:11pm

[SOLVED] SES + nrF SDK 14.2 : "stray # in program " error at compilation

Hi guys,

I am working on a nrF52832 project and want to use SES since there is a license agreement with nordic based projects.

I am using freertos from nordic SDK 14.2, and I have an error when compiling "port.c" from the freertos driver.

The file "port.c" contains some assembly code. For some reason, Embedded studio and GCC can't compile the file and report the following errors :

stray "#" in program

Do you have any idea what I can do to fix this issue ?

Thank you,
Best regards



Date of registration: Jan 22nd 2018

Posts: 7


Wednesday, March 7th 2018, 7:18pm

Update : There are different version of the port.c file depending on the compiler/assembler. I wasn't using the right one. Issue is fixed when using the GCC file.



Super Moderator

Date of registration: Jan 2nd 2017

Posts: 1,048


Friday, April 13th 2018, 5:05pm


Great to hear that you are up and running again.
We will consider this thread as solved now.

Best regards,
Please read the forum rules before posting: Forum Rules

Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
Should you be entitled to support contact us per e-mail.
The following contact form can be used for this: