Monday, March 19th 2018, 11:56am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



Date of registration: Mar 6th 2018

Posts: 1


Monday, March 12th 2018, 8:36am

Timeout while blank checking, RAMCode did not respond in time


I would like to program TI LM3S5B91 MCU but this message appear:

- ERROR: Timeout while blank checking, RAMCode did not respond in time

And FAIL the programming. Our costumer gave me the project file and the hex file also. I used the same SEGGER J-Flash programmer and the same version of the software V6.00 as our customer used, but did not working for me.

Here is the LOG:

Connecting ...
- Connecting via USB to J-Link device 0
- Target interface speed: 4000 kHz (Fixed)
- VTarget = 3.316V
- Initializing CPU core (Init sequence) ...
- Initialized successfully
- Target interface speed: 4000 kHz (Fixed)
- CPU clock frequency: 16225 kHz (Auto detected)
- Connected successfully
Programming and verifying target (178548 bytes, 7 ranges) ...
- Start of preparing flash programming
- End of preparing flash programming
- Start of determining dirty areas in flash cache
- End of determining dirty areas
- CPU is running at 16224 kHz.
- Start of erasing sectors
- Start of blank checking
- End of blank checking
- Erasing range 0x00000000 - 0x00003FFF (016 Sectors, 16 KB)
- Start of blank checking
- ERROR: Timeout while blank checking, RAMCode did not respond in time
- ERROR: Failed to blank checking.
Failed to execute RAMCode for blank check!
- End of blank checking
- Erasing range 0x00004000 - 0x00007FFF (016 Sectors, 16 KB)
- End of erasing sectors
- Start of flash programming
- End of flash programming
- 0x0000 - 0xBFFF (048 Sectors, 48 KB)
- 0xE800 - 0xF3FF (003 Sectors, 3 KB)
- 0x10000 - 0x113FF (005 Sectors, 5 KB)
- 0x13C00 - 0x2B3FF (094 Sectors, 94 KB)
- 0x38000 - 0x3F3FF (029 Sectors, 29 KB)
- 0x3FC00 - 0x3FFFF (001 Sector, 1024 Bytes)
- Start of verifying flash
- End of verifying flash
- Start of restoring
- End of restoring
- ERROR: Failed to program and verify target
Disconnecting ...
- Disconnected

Best Regards,



Date of registration: Mar 7th 2018

Posts: 9

Location: Toronto, Ontario, Canada

Occupation: Engineer


Monday, March 12th 2018, 1:46pm

I oftentimes get this if I've protected the Flash on my Nordic nRF51822 designs. At least for me, in those cases, I manually use w4and mem32 to erase the entire flash, reset the ARM with the r command and then I am able to use the Segger high level functions.

I don't know if this will help in your case, but it might be worth a try.


Super Moderator

Date of registration: Jan 2nd 2017

Posts: 817


Thursday, March 15th 2018, 10:10am


Thank you for your inquiry.
Such an issue is not known to us.
Generally we do not provide support for older software releases if there are newer available.
Could you update to the latest version and see if the behaviour changes?
What is the serial number of the J-Link you were using for flashing?
Are you using custom hardware or an eval board? If eval board which one?
Could you provide us with the project file and hex file for reproduction?

Best regards,