Monday, May 21st 2018, 3:11pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



Date of registration: Mar 15th 2018

Posts: 1


Thursday, March 15th 2018, 4:31pm

[ABANDONED] Embedded Studio crashes on ubuntu

version: Segger Embedded Studio v3.34a for arm
OS: Linux 4.13.0-36-generic #40-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux - Ubuntu 17.10

installation worked without any percievable problems

steps to reproduce:
launch using system menu. During initialization, it crashes.

I have tried to remove all user config files in ~/.segger and ~/.config/

I don't know how to find the crash log if any. There are no details when it crashes to help me troubleshoot.
Possibly I could use some help in diagnosing the problem.



Super Moderator

Date of registration: Jan 2nd 2017

Posts: 1,048


Monday, March 19th 2018, 11:33am

Hello Lance,

Thank you for your inquiry.
Such an issue is not known to us.
Did the issue start right after installation or did you create a project and the issue appeared afterwards?
Could you provide us with your emProject file and emSession file if you created a project?
Could you attach the settings.xml as well which is located in the Embedded Studio user folder?

After you attached the requested files does deleting the settings.xml and emSession file (if available) solve the issue?

Best regards,
Please read the forum rules before posting: Forum Rules

Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
Should you be entitled to support contact us per e-mail.
The following contact form can be used for this:

Achim O.


Date of registration: Sep 13th 2017

Posts: 7


Thursday, March 29th 2018, 9:05am

Had a similar problem some months ago. Look here: