Tuesday, June 27th 2017, 4:02am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

pbuonado

Beginner

Date of registration: Jun 24th 2010

Posts: 3

1

Thursday, June 24th 2010, 5:37am

[SOLVED]J-Link TCP/IP server with IAR j-Link

When starting a remote IAR debug session via the J-Link TCP/IP server with an IAR branded j-Link for ARM dongle, I get the following error dialog on the TCP/IP server:

"Unknown EMU command #196 received. Discontinuing parsing of communication."

The debug session then freezes until I click OK on the dialog. After that, things work fine.

The problem does not occur with an ADI branded mIDAS-Link for ARM.

Is there any way to correct this error? Alternatively, is there a way to have the TCP/IP server NOT freeze when it hits this command?

TCP/IP Server V4.14d
IAR J-Link ARM v8.0
Analog Devices mIDAS-Link

pbuonado

Beginner

Date of registration: Jun 24th 2010

Posts: 3

2

Thursday, July 1st 2010, 8:17pm

anybody?

SEGGER - Alex

Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,505

3

Friday, July 16th 2010, 2:37pm

Hi,

will be fixed in the next beta version (V4.15s).


Best regards
Alex

Date of registration: Aug 6th 2010

Posts: 2

4

Friday, August 6th 2010, 7:07am

J-Link TCP/IP server with IAR j-Link

J-Link support is integrated in most professional IDEs such as IAR, Keil, ... TCP/IP serverincluded, which allows using J-Link via TCP/IP networks..


__________________________________________________________



Want to get-on Google's first page and loads of traffic to your website? Hire a SEO Specialist from
Ocean Groups seo specialist