Sunday, May 20th 2018, 11:57am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

AlanJ

Beginner

Date of registration: Feb 1st 2008

Posts: 2

1

Friday, February 1st 2008, 11:22pm

Intermittent errors erasing Arm7

Hi

I'm using J-Flash on Windows XP, connected through J-Link to an ARM7 JTAG. Once in 10 or 20 times, on average, I get the following error:

- Erasing affected sectors ...
- Erasing sector 0, 1, 2, 3, 5, 6, 7, 23, 24, 25, 26
- ERROR: PC of target system has unexpected value after erasing sector. (PC = 0x00000000, CPSR = 0x400000D3, LR = 0x0020019E)!
- ERROR: Failed to erase sectors
- ERROR: Failed to auto program target



Is there any information that can be known from this error message? Does it point to any one specific JTAG pin?

Thanks,

AlanJ

SEGGER - Rolf

Super Moderator

Date of registration: Nov 21st 2007

Posts: 65

2

Saturday, February 2nd 2008, 9:12pm

Yes, the error message allows some educated guesses.
The PC is 0, which points to a RESET.
The source of the reset could be RESET pin, watchdog or drop in power
during erase. Maybe you can get these potential causes and let me know if this helps.

Rolf

AlanJ

Beginner

Date of registration: Feb 1st 2008

Posts: 2

3

Wednesday, February 6th 2008, 6:16pm

I found it: My Reset line connection was breaking up (i.e. intermittently touching). Once I fixed it the problem seems to have gone away. Thanks for your help!

Alan